11lb Sausage Stuffer Broken!

  • Team Blue

    I did some sausage processing last week and toward the end of the session, I noticed that it was becoming harder and harder to crank the plunger out of the tank.

    I only use the fast crank to pull the plunger out of the stuffer and the other gears for stuffing.

    But, it seems like the gears are catching and not running smoothly. It works much better but is still noticeable when stuffing, but is much more prevalent when removing the plunger with the fast gears.

    I took the top off and checked out the gearbox and I cannot find any gears that appear to be damaged. There was a small little bit (really not that much) of metal dust on the gear housing.

    I see that there are some set screws that I tried adjusting, but that just made the crank handle higher and didn’t seem to fix the problem.

    To me, it just seems like the gears are not seated together as far as they should.

    I just bought this stuffer on 11/2016, so I am guessing well beyond the warranty period, but should I really have to be dealing with gearbox issues this soon?

    Are there any other possible fixes? Or is my only option to order a new gearbox?

    I am going to send a message to Walton’s Customer Service as well but thought I would ping this group to see if you have any other suggestions.

    Thanks,

    NDKoze

  • Power User Canning Team Orange Regular Contributors

    make sure that your studs that hold your canister are tight to the frame i had a similar problem happen once

  • Power User

    Clean and lube?
    Sometimes old lube will cake up

  • Team Blue

    craigrice That is an interesting suggestion. I’ll have to check that, but it seems unlikely because the issue was still occurring when I took the piston off of the rack the issue still occurred.

  • Team Blue

    glen I regularly apply white oil and/or silicone spray, but haven’t used any lube.

    I did not see any caked-up lube when I was inspecting the gear box.

    Everything looked great. The gears did not appear to have any bad spots and looked good from what I could tell. It just seemed like they were binding.

  • Team Blue Power User Traeger Primo Grills PK Grills Canning Sous Vide Community Moderator

    If you could post some pictures that may help to diagnose the issue. Jonathon

  • Power User Canning Team Orange Regular Contributors

    did you check the piston rod to see if it has a curve to it possibly from extra pressure being applied

  • Team Blue

    I vote for the piston rod. 2nd guess would be a brass bearings holding the sprag may be dry. Less ratio advantage going up than the power stroke going down.

  • Regular Contributors

    Confirming the actual problem might require full disassembly, clean up and detailed inspection of the suspected parts. A bent piston screw could be ruled out with a steel ruler or other straight edge.

  • Team Blue

    When you disassemble you destroy the indicators of failure. Anything changed could cause a 2nd issue that compounds the initial failure. Failures are then compounded. Study first, take pics of everything, and dissemble with the knowledge to norm up what you’ve dissembled

  • Team Blue

    I will check on the piston rod as I can see where that could be an issue. This seems like a likely cause since I am not seeing any indication of gear damage.

    I will take some pictures too.

    We were processing at my parent’s house and I left the stuffer down there since I figured I just needed a new gearbox, and I won’t be back until Easter most likely. But, I am glad that I posted here before ordering the gearbox as your suggestions seem like they might help diagnose the issue prior to having to order any parts.

    So, I will check all of these great suggestions that you have made and update this post with what I find.

  • Team Blue Admin Walton's Employee Power User

    NDKoze Check out this part of this video, https://youtu.be/t4YLATEMDfs?t=217 you want to make sure the gears are centered on those holes before tightening everything. I also would absolutely recommend some lube if you bought it 5 years ago and haven’t done that. 5 Years could either be a lot of wear and tear or little depending on how often it gets used. It is not a machine that is going to degrade by not being used. I mean, yes, the gasket could dry up and the gears might need a little lubricant but other than that it should be good. let me know if you continue to have issues!

  • Team Blue

    Jonathon I will check the alignment over Easter weekend.

    I don’t really use the stuffer that much. I would say 3-4 times per year. Probably around 300-400 pounds pushed through it per year.

    What type of lube should I get? Any suggestions?

  • Team Blue Power User Traeger Primo Grills PK Grills Canning Sous Vide Community Moderator

    NDKoze I would suggest a food grade white grease.

Log in to reply
 

Suggested Topics

  • 6
  • 4
  • 3
  • 18
  • 5

Community Statistics

22
Online

15.0k
Users

3.2k
Topics

34.0k
Posts

About Meatgistics

Meatgistics is brought to you by Walton's (waltonsinc.com). Meatgistics is a community site, knowledgebase, forum, blog, learning center, and a sharing site. You can find help and ask questions about anything related to meat processing, smoking and grilling meats, plus a whole lot more. Join Austin & Jon from Walton's and sign up for our Meatgistics community today.
Change Text Size